BaseDocumenter, to document your Base applications

BaseDocumenter is a software tool producing a full documentation of a LibreOffice Base application.

★ ★ ★ ☆ ☆
Base Extensions
Download latest

latest release: 2024-03-21 11:07:17

Description

The documentation produced by BaseDocumenter is bundled as one set of static HTML pages.
The layout of the produced HTML pages is highly customizable.

The documentation describes in detail all the items (tables, queries, Basic procedures, ...) being part of the Base application.

Additionally it identifies all the dependencies between items. E.g. a query might use one or more tables. Knowing exhaustively which items are used by other items is invaluable for the developer of the application. This knowledge allows for example a detailed impact analysis of design changes.

Dependencies are of 2 types:

  • parent/child: e.g. a field is the child of a table.
  • uses/used by: e.g. a query uses a table or a table is used by a query. In BaseDocumenter, such dependencies are very simply revealed by the use of hyperlinks. Clicking on one of them makes the browser jump to the description of the linked item.

The software includes also

  • a Basic parser to identify a.o. which procedures are called by which ones
  • a SQL beautifier to make simple or complex SQL statements much more readable

Full documentation of the software HERE.

Striking examples HERE and HERE.

The recommended release is LibreOffice 6.2 or later, including up to 7.2.
Before installing the extension, rename the downloaded file from basedocumenter.oxt to BaseDocumenter.oxt.
Then proceed as usual.

Additional documentation: http://www.access2base.com/basedocumenter

Homepage: http://www.access2base.com/basedocumenter

Release List

Release Description Compatibility Operating Systems License Release notes   0.6.0 Show 1-N relationships between tables. List secundary indexes and involved fields. 6.0 Linux, Windows, macOS MPL Download 0.5.1 Fix error when 'Collect data statistics' deselected 6.0 Linux, Windows, macOS MPL Download 0.5.0 First public release.
Minimal requirement: LibreOffice 6.0, recommended: LibreOffice 6.1
6.0 Linux, Windows, macOS MPL Download

Other Extensions

Access2Base

VBA for MSAccess emulator

04-2024

1826

★ ★ ☆ ☆ ☆

BaseDocumenter, to document your Base applications

BaseDocumenter is a software tool producing a full documentation of a LibreOffice Base application.

04-2024

761

★ ★ ★ ☆ ☆

Feedback

★ ★ ★ ☆ ☆

Post your review

You cannot post reviews until you have logged in. Se connecter.

Reviews

  • Vassilis Kilias 29 janv. 2021 à 12:10 (Il y a 3 année)

    ★ ★ ★ ★ ☆

    Nice work!
    I report an installation bug: Windows 10 LO 6.4.0.3 (x64)
    Cannot add repository - failed at BD_Utils 478
    BASIC runtime error.
    An exception occurred
    Type: com.sun.star.script.provider.ScriptFrameworkErrorException
    Message: <class 'KeyError'>: 'BaseDocumenter.oxt'
    File "C:\Program Files\LibreOffice\program\pythonscript.py", line 1053, in getScript
    self.provCtx.uriHelper.getStorageURI(scriptUri) );
    File "C:\Program Files\LibreOffice\program\pythonscript.py", line 423, in getStorageUrlFromPersistentUrl
    package = self.mapPackageName2Path[ packageName ]
    Thank yo for the work!

    • Jean-Pierre Ledure 10 juil. 2021 à 18:14 (Il y a 3 année)

      Sorry for the late answer.
      I discovered only recently that the last site revamping set all the uploaded filenamess (all the .oxt's) arbitrarily in lower case.
      So, RENAME the downloaded basedocumenter.oxt file into BaseDocumenter.oxt and REINSTALL the extension.
      The wrong file name prevents the documenter from finding a Python helper script that it needs, at least on Linux.
      Sorry for the inconvenience.

  • Aidan Karley 16 oct. 2020 à 02:58 (Il y a 4 année)

    ★ ★ ☆ ☆ ☆

    It is an interesting idea, but doesn't seem to be working at all on "Version: 6.4.6.2 (x64)", even after downloading the templates and creating the new data repository, per instructions.

    • Jean-Pierre Ledure 26 oct. 2020 à 17:44 (Il y a 4 année)

      It's a pity that you could not make it work ...

      But, the description of the issue(s?) is very brief ... Could you precise what happened ?

      Thanks.

RSS feed for reviews on this page | RSS feed for all reviews