validar Validar CPF e CNPJ

Extensão que implementa as funções VALIDACPF e VALIDACNPJ no LibreOffice Calc.


"Validar CPF e CNPJ" implements the VALIDACPF and VALIDACNPJ functions in LibreOffice Calc. It's developed for brazilian users.

★ ★ ★ ☆ ☆
Calc Extensions
Download latest

latest release: 2020-03-05 23:15:29

Description

Esta extensão foi desenvolvida durante as oficinas da Latinoware 2011 (http://www.latinoware.org), de 19 a 21 de outubro de 2011 em Foz do Iguaçu/PR. Instale a extensão e reinicie o LibreOffice. Ao abrir novamente o LibreOffice Calc, as funções VALIDACPF e VALIDACNPJ estarão disponíveis para uso em fórmulas de planilha. Para utilizá-las, basta abrir o Assistente de funções e localizar a função desejada. O número a ser verificado deve ser incluído como parâmetro na função sem a utilização de traços ou barras. Caso o número a ser verificado inicie com um zero à esquerda, insira o número entre aspas. O resultado será verdadeiro (1) se o número estiver correto ou falso (0) se o número estiver incorreto.

Additional documentation: http://wiki.documentfoundation.org/PT-BR/Extensions/Projects/CpfCnpj

Release List

Release: 0.9 – Primeiro release da extensão Validar CPF e CNPJ (0.9).

Compatibility: 3.3
Operating Systems:
License: LGPL
116 downloads

Feedback

★ ★ ★ ☆ ☆

Post your review

You cannot post reviews until you have logged in. Login Here.

Reviews

  • Andreas Funke Apr 7, 2023, 2:23 PM (6 months ago)

    ★ ★ ★ ★ ★

    Funciona perfeitamente, implementação eficiente em java. Requer formatação prévia do cpf no caso de zeros ("0"s) à esquerda para o formato com 9+2 dígitos, pois sem este pré-processamento* a função resultará CPF inválido pela omissão destes zeros como normalmente ocorre em campos numéricos. It's an efficient java-programmed extension that works perfectly. It requires pre-processing of the CPF input string so that it conforms to the 9+2 digit format, which may be considered not validated if it begins with one or more "0"s.
    *e.g. =TEXTO(C2;"000########") - substituir "C2" pelo campo com o número do CPF.

  • Gilberto Schiavinatto Dec 4, 2020, 7:56 PM (3 years ago)

    ★ ☆ ☆ ☆ ☆

    Não esta instalando em 04/12/2020.

RSS feed for reviews on this page | RSS feed for all reviews